Quote:
"Amigos y nadie más. El resto, la selva"
-- Jorge Guillén




IPv6 ready!

Well, thanks to my wonderful ISP I now have a IPv6 network stack ready!!

IPv6 Ready

It took a bit of adapting to get my Cisco router to work with IPv6 over PPPoE, but it wasn't hard. Here is my configuration:


vpdn enable
vpdn ip udp ignore checksum

vpdn-group 1
request-dialin
protocol pppoe

ipv6 unicast-routing
interface Ethernet0
ip tcp adjust-mss 1452
ip address 10.0.0.2 255.255.255.0
ipv6 address xxxx:xxxx:11:11::2/64

interface Ethernet1
no ip address
duplex auto
pppoe enable
pppoe-client dial-pool-number 1

interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ipv6 address autoconfig default
ipv6 enable
ipv6 nd other-config-flag
ppp authentication pap chap callin
ppp chap hostname MY_USER
ppp chap password 0 PASSWORD
ppp pap sent-username MY_USER password 0 PASSWORD

ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 0.0.0.0 0.0.0.0 Dialer1 dhcp

ip nat inside source list 101 interface Dialer1 overload

access-list 101 permit ip 10.0.0.0 0.0.0.255 any


Comments


New Comment

* optional

http://example.com